iPhone 5s, iPhone 6, iPad Air, iPad mini и другие старые устройства Apple получили очень важное обновление

Вчера было выпущено обновление iOS для iPhone и iPad, которое исправляет уязвимости и проблемы безопасности нескольких видов, в основном для устройств, выпущенных до iPhone 7, то есть до 2016 года.

В iOS 12.5.5 пользователи найдут исправления уязвимостей, связанных с CoreGraphics, WebKit и XNU. Для XNU была обнаружена уязвимость, позволяющая вредоносному приложению выполнять произвольный код с привилегиями ядра. Apple отметила, что «эксплойт для этой проблемы реально существует», но не сообщила, что указанная уязвимость активно использовалась.

Для WebKit «злонамеренно созданный веб-контент» потенциально может привести к выполнению произвольного кода. Эта уязвимость отличается от проблемы, связанной с XNU, поскольку Apple  известно о случаях, в которых эта проблема WebKit «могла активно использоваться».

iPhone 5s, iPhone 6, iPad Air, iPad mini и другие старые устройства Apple получили очень важное обновление

Уязвимость CoreGraphics работала путем обработки вредоносного PDF-файла. Эта уязвимость могла инициировать выполнение произвольного кода через указанный вредоносный PDF-файл. Исправление устраняет целочисленное переполнение за счет улучшенной проверки ввода.

Это обновление обязательно для пользователей iPhone 5s, iPhone 6 и 6 Plus, iPad Air (1-го поколения), iPad mini 2, iPad mini 3 и iPod touch 6-го поколения. Вы можете загрузить это обновление программного обеспечения, открыв Настройки — Общие — Обновление программного обеспечения.

 

Источник: iXBT

,

Читайте также

Меню